[rešeno] SmartLink modem, Laptop problemi

Slika korisnika jovir

I konacno kupim ja laptop.
I birao konfiguracije i izabrao model sa nazovi "conexant" cipom i bio siguran da ce to raditi pod Slackware-om. Ali, imam sta da vidim, to uopste nije bio conexant modem vec Motorola. Vec izgubljene nade za surf pod linuxom, skripta "scanModem" mi da nadu u vidu Smart Link drajvera (binarnog za gcc 4.1). Odradim instalaciju, pokrenem testiranje modema i to mi izbaci besprekoran odziv. Vec pun srece, posle (ovo znaju slmodem-ovci):

[email protected]:/home/jovir# slmodemd --alsa -c SLOVENIA hw:0,6
SmartLink Soft Modem: version 2.9.11 Aug  6 2007 22:02:27
symbolic link `/dev/ttySL0' -> `/dev/pts/2' created.
modem `hw:0,6' created. TTY is `/dev/pts/2'
Use `/dev/ttySL0' as modem device, Ctrl+C for termination.

samouvereno krenem da se konektujem, krene "Trazim modem", pa "Modem je spreman", pa "Inicijalizujem modem", kad ne lezi vraze, izbaci u konzoli:

error: cannot setup hw params for playback: Invalid argument

i kppp odziv "Nema noseceg signala".
Modem je sa "HDA card" i radi i uz pomoc ALSA drajvera.
Dobri ljudi, sta dalje?

I da, ubi me rad bez misa, pa kako se ponasaju USB misovi na linuxu i posto su?
Hvala!

0
shadow

Komentari

Slika korisnika dokman

Odg: [rešeno] SmartLink modem, Laptop problemi

iskljucio sam i ponovo pokrenuo snd-intel8x0m, i ponovo pokrenuo scanModem i sad mi je izbacio
Analysing card in PCI bus 00:1f.6, writing to scanout.00:1f.6
        Modem with PCI ID 8086:24c6 is in the software modem category.
Checking for match with Archived softmodem information.
IDENT=slmodemd
Using scanout.00:1f.6 data, and writing guidance to ModemData.txt
Writing Intel.txt
Writing Smartlink.txt

Writing residual guidance customized to your System.
  A subfolder Modem/  has been written,  containing these files with more detailed Information:
------------------------------------------------------------------------------------------
1stRead.txt    Bootup.txt      DriverCompiling.txt  InfoGeneral.txt
Intel.txt      ModemData.txt    Rational.txt        Smartlink.txt
SoftModem.txt  Testing.txt      UNSUBSCRIBE.txt      YourSystem.txt
dmesg.txt      scanout.00:1f.6  wvdial.txt
-------------------------------------------------------------------------------------------
      Please read 1stRead.txt first for Guidance.

kakva je to zajebancija, i Intel i SmartLink?

Skinuo sam ovaj slmodemd, pa cu probati sa njim.
a sta je sa ovim ungrab, cemu to sluzi?

Slika korisnika dukenukem_4d

Odg: [rešeno] SmartLink modem, Laptop problemi

sad ima još podataka u ovim datotekama koji se razlikuju od onih gore Wink

Slika korisnika dokman

Odg: [rešeno] SmartLink modem, Laptop problemi

Uspeo sam instalirati slmodem-2.9.11-20090222.tar.gz >:D , probam se konektovati preko KPPP i zakuca na initializing modem, probao sam query modem i dobijem sliku

kad sam rasetovao masinu nista nece da radi, mislim na ovo sa modemom, morao sam odraditi
# mknod -m 600 /dev/slamr0 c 242 0
# /usr/sbin/slmodemd --country=USA /dev/slamr0
postoji li nacin da se doda negde komanda da se ovo pokrece prilikom boot-a?

Slika korisnika dukenukem_4d

Odg: [rešeno] SmartLink modem, Laptop problemi

občno može u /etc/rc.d/rc.local da se dopiše ,bilo šta Laughing out loud
(mada u distoima praktikuju poseban servis da dodaju)

zakuca se modem ili ceo komp ? ili samo pukne pppd ?

Slika korisnika dokman

Odg: [rešeno] SmartLink modem, Laptop problemi

dobro, to se onda da resiti!

kad u KPPP idem na connect, ide modem ready, dailing 042..., initializing modem i tu stane, mogu da ga prekinem u bilo kom trenutku, a komp radi normalno.
query modem radi cini mi se normalno

Slika korisnika dokman

Odg: [rešeno] SmartLink modem, Laptop problemi

Napravio sam sranje, upisao sam u /etc/rc.d/rc.local
mknod -m 600 /dev/slamr0 c 242 0
/usr/sbin/slmodemd --country=USA /dev/slamr0

sad pri boot-u izbacuje
SmartLink Soft Modem: version 2.9.11 Dec 14 2009 00:47:22
symbolic link `/dev/ttySL0' -> `/dev/pts/2' created.
modem `slamr0' created. TTY is `/dev/pts/2'
Use `/dev/ttySL0' as modem device, Ctrl+C for termination.
i tu stane.

koji je postupak da sa livecd-a podignem sistem i editujem ovaj rc.local file i izbrisem
/usr/sbin/slmodemd --country=USA /dev/slamr0 ?

mislim da ce to resiti problem, bar da podigne sistem?!

Slika korisnika dokman

Odg: [rešeno] SmartLink modem, Laptop problemi

Uspeo sam srediti ovo sto sam zabrljavio, ali jos uvek ostaje problem, postoji li nacin da se ovaj salmr0 automatski pravi pri boot-u, pokusavao sam naci neko resnje na netu ali nema ili ja trazim na pogresnom mestu?

Slika korisnika dukenukem_4d

Odg: [rešeno] SmartLink modem, Laptop problemi

probaj ovako ,napravi skriptu
(da se nekako kratko zove recimo initsl  )

#!/bin/sh

mknod -m 600 /dev/slamr0 c 242 0
/usr/sbin/slmodemd --country=USA /dev/slamr0

promeni joj executable flag ,stavi je u /usr/local/bin/
pa je pokreći kao root :-\ za sada dok ne smislimo gde da se ubaci

initsl

(verovatno piše negde po mailing listama ali se nije otvaralo juče)
u principu može i kao kde autostart ima par mesta gde bi išlo

Slika korisnika dokman

Odg: [rešeno] SmartLink modem, Laptop problemi

Zasto se ovo desava
[email protected]:/home/dokman# wvdialconf /etc/wvdial.conf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: S0  S1  S2  S3
WvModem<*1>: Cannot get information for serial port.
ttySL0<*1>: ATQ0 V1 E1 -- OK
ttySL0<*1>: ATQ0 V1 E1 Z -- OK
ttySL0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttySL0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttySL0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttySL0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttySL0<*1>: Modem Identifier: ATI -- SmartLink Soft Modem
ttySL0<*1>: Speed 4800: AT -- OK
ttySL0<*1>: Speed 9600: AT -- OK
ttySL0<*1>: Speed 19200: AT -- OK
ttySL0<*1>: Speed 38400: AT -- OK
ttySL0<*1>: Speed 57600: AT -- OK
ttySL0<*1>: Speed 115200: AT -- OK
ttySL0<*1>: Speed 230400: AT -- OK
ttySL0<*1>: Speed 460800: AT -- OK
ttySL0<*1>: Max speed is 460800; that should be safe.
ttySL0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found a modem on /dev/ttySL0.
Modem configuration written to /etc/wvdial.conf.
ttySL0<Info>: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
[email protected]:/home/dokman#

mislio sam da je bog onoga sto u toku boot-a iskljuci slamr pa ga ponovo ukljuci, pa sledeci put odradim
[email protected]:/home/dokman# rmmod slamr
[email protected]:/home/dokman# modprobe slamr
[email protected]:/home/dokman# mknod -m 600 /dev/slamr0 c 242 0
[email protected]:/home/dokman# /usr/sbin/slmodemd -c BULGARIA /dev/slamr0
SmartLink Soft Modem: version 2.9.11 Dec 14 2009 00:47:22
symbolic link `/dev/ttySL0' -> `/dev/pts/2' created.
modem `slamr0' created. TTY is `/dev/pts/2'
Use `/dev/ttySL0' as modem device, Ctrl+C for termination.
ali svejedno, nista se ne menja.

A wvdial kad pokrenem
[email protected]:/home/dokman# wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT042110011
--> Waiting for carrier.
ATDT042110011
NO CARRIER
--> No Carrier!  Trying again.
--> Sending: ATDT042110011
--> Waiting for carrier.
ATDT042110011
--> Timed out while dialing.  Trying again.
^CCaught signal 2:  Attempting to exit gracefully...
--> Disconnecting at Thu Dec 17 11:49:01 2009
[email protected]:/home/dokman#

i ovaj Waiting for carrier. se ponavlja u nedogled.

Slika korisnika kosmi

Odg: [rešeno] SmartLink modem, Laptop problemi

Probaj da staviš u wvdial.conf sledeću liniju:
Carrier Check = off
mada verovatno će trebati i:
Stupid Mode = on
i možda itd. (o tome ako) :Smile.