Slackware Linux 13.0

25 odgovora [Poslednji unos]
Spooky13
Slika korisnika Spooky13
Offline
User
Član od: 29/05/2006

heh.. da prozborim i ja koju.. Smile

sa Linuxom prvi put sam se poigrao davne 2002/2003. neki Mandrake (sadasnja Mandriva), neki SuSE... a Slack prvi put okusih u verziji 10.0 (iako sam tada nesto zeznuo komp sa njim, particije il nesto tako.. Slack mi se odmah svideo zbog jednostavnosti - a drugi, men' kao pocetniku, pricase drugacije Laughing out loud)..

dual-boot mi tako stajase godinu i nesto.. i kad je izasao Slackware 11.0 to je bilo to.. za mene od tad ne postoji nista drugo (mozda navika, mozda jednostavnost, mozda prokletstvo Matematickog fakulteta Smile ko ce ga znati.. Smile)

na desktop masini sve do letos mi je stajala 11.0-ica (rucno dodavani HAL, D-bus.. i ostalo kako je izlazilo) i to je sve sljakalo perfektno..

trenutna situacija.. desktop i laptop masina teraju 12.2 i to necu menjati bar do sledece verzije Slack-a..

13.0 sam skinuo cim se pojavila a probah je par dana kasnije (ispitni rok u jeku pa se nemade vremena ranije)..

ispod haube to je isti onaj stari Slack samo jos malo ispeglan i osvezen novim verzijama programcica (i jos nekim novitetima ponajvise u samom kernelu).. stekao sam utisak da mi se za nijansu brze dize 13.0 nego 12.2 i sve je proradilo iz prve, nisam imao nikakvih problema (ono na stranim forumima narod sto se zali na DHCP i ostale zezancije.. to se kod mene ne desava).. svidja mi se sto su konacno dodali jos neke 'must have' programcice u "osnovnu ponudu" (kao npr. mplayer)

e sad, razlog zasto necu jos preci na 13.0 za stalno.. nemam potrebu za 64-bit izdanjem.. i ono glavno, graficko okruzenje mi je KDE i ovo novo KDE 4.x mi je jos bagovito i fali mu brdo stvari.. ne smetaju mi fensi detalji, cak mi se to i svidja.. al mi smetaju sitnice.. znaci gluposti.. iskljucim potvrdu za logout i kad hocu da se izlogujem ne mogu.. zvucna (samo u KDE-u) je pukla iz cistog mira (nisam jos siguran tacno sta je proizvelo al ono sto sam uradio, ukljucio sve slajdere u mix-u, dodao precice za kontrolu zvuka i ostao mi amarok kada je ugasena session.. prilikom sledeceg logovanja zvuka nema pa nema, probao sve zivo).. itd. mrzi me da nabrajam..

e da, jos jedna zanimljiva sitnica.. pricam o staroj masini (Celeron III 800 MHz, 448MB RAM, grafika Nvidia 64MB Shock)) 12.2 + compiz-fusion radi skoro glatko (zuzece procesora uopste nije preterano) dok 13.0 sa vec preinstaliranim compizom i zezancijama malkice secka sa nekim efektima i procesor skace previse (nove masine su jake i ovo se nece toliko osetiti, cisto napomenuh ko tera nesto starije Wink).. i tako..

kad prodje ispitni rok malo cu vise da cimam 13.0 mozda isplovi jos neka pozitivna/negativna sitnica.. Smile pozz

__________________

All we have to decide is what to do with the time that is given to us. J.R.R. Tolkien

jovir
Slika korisnika jovir
Offline
User
Član od: 29/05/2006

Jedna od novosti je i da je HAL zadužen za desktop, tako da konfiguriše ekran i bez fajla /etc/X11/xorg.conf.

Problemi:
- Ne radi mi akceleracija na intel grafici na laptopu, stari xorg.conf ne funkcioniše, a nemam baš vremena za bacanje.
- Meni na KDE 4.2.4 ne može da se ažurira kako treba.

12.2 ostaje na stonom računaru i na laptopu na poslu, zasada...

Andersen
Slika korisnika Andersen
Offline
User
Član od: 04/04/2007

marelli wrote:

@Andersen

Koje graficko okruzenje koristis na PIII?

KDE, pre nego sto sam ga instalirao mislio sam da ce da gnjavi, ali sad mi se cini da po brzini ne zaostaje za 3.5.10. Naravno, nisam ga zatrpavao sa nekim preteranim dodatnim 'cool' efektima Smile

Jovir wrote:

Problemi:
- Ne radi mi akceleracija na intel grafici na laptopu, stari xorg.conf ne funkcioniše, a nemam baš vremena za bacanje.

Cini mi se da sam video neke alternativne drajvere za intelove kartice na http://www.slackware.com, verovatno su i na instalacionom disku, nisam proveravao. Mozda neki od njih resi problem.

ak-87
Slika korisnika ak-87
Offline
User
Član od: 29/05/2006

@Jovir

Ovo sto je spomenuo Andersen... Robby Workman je na LQ forumu zatrazio od ljudi da testiraju drajvere za Intele kartice jos dok je 13-ka bila RC. Na kraju su izgleda uvrstili onu verziju drajvera koja je najbolje prosla na testovima, a ostavili i druge da se koriste po potrebi. Nisam gledao na disku, ali evo nadjoh na jednom od mirrora:

http://ftp.linux.cz/pub/linux/slackware/slackware-13.0/extra/xf86-video-intel-alternate/

Ne skodi da pokusas. Inace, mislim da bez obzira sto HAL automatski konfigurise X, ti i dalje mozes da napravis rucno datoteku i nju koristis za konfiguraciju. Nisam samo siguran da li treba neku opciju proslijediti (hvala Bogu pa mi jos nije trebalo). X -configure, pa polako. Smile

Sto se tice KDE4... Jedan dugogodisnji korisnik Slack-a (cini mi se od 8-ice) je instalirao KDE3 sa 12.2 na 13.0 i kaze da radi. Meni je to malo "divlji" nacin (ja bih to radije ponovo iskompajlirao), ali ako nadjem link okacicu. Mozda ti bude od koristi. Wink

Edit:

Evo link: http://linuxcritic.wordpress.com/2009/08/31/upgrading-from-kde-4-2-4-to-kde-3-5-10-in-slackware-13/

tux666
Slika korisnika tux666
Offline
User
Član od: 10/02/2008

ak-87 wrote:

2.26.3 za 13-ku http://gnomeslackbuild.org/

Probao sam na 12.0 ovu distribuciju GNOME-a za Slack i bio sam zadovoljan. Navodno je najkvalitetniji, jer vrsi najmanje izmjena originalnih Slack paketa/skripti.

Ako se vratim na slack, probacu svakako. Hvala, vec zaboravio za ovo.

Kix
Slika korisnika Kix
Offline
User
Član od: 29/05/2006

Da ne bi otvarao novu temu postavicu pitanje ovde.

U pitanju je dual boot winxp i slack13
Instalacija je protekla bez problema medjutim prolikom izbora sistema Linux radi normalno ali windows se ne podize ?

# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
# Append any additional kernel parameters:
append=" vt.default_utf8=0"
boot = /dev/hda

# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
  bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
  bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used.  We don't specify it here, as there's just one column.
  bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
  bmp-timer = 65,27,0,255

# Standard menu.
# Or, you can comment out the bitmap menu above and
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Wait until the timeout to boot (if commented out, boot the
# first entry immediately):
prompt
# Timeout before the first entry boots.
# This is given in tenths of a second, so 600 for every minute:
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Windows bootable partition config begins
other = /dev/sda
  label = Windows
  table = /dev/sda1
# Windows bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/hda1
  label = Linux
  read-only
# Linux bootable partition config ends

ak-87
Slika korisnika ak-87
Offline
User
Član od: 29/05/2006

@Kix

Cini mi se da ti nije dobro unesena oznaka Win particije. Kod tebe je sda1, a LILO i root particija su na hda. Otvori konzolu, pa kao root otkucaj slijedecu komandu i stavi nam ovdje izlaz:

#fdisk -l

Spooky13
Slika korisnika Spooky13
Offline
User
Član od: 29/05/2006

Prosto mi je neverovatno da je lilo (ono automatsko konfigurisanje tokom instalacije) zeznuo config kod basic dual boot sistema (Windows/Slack).. Jesi cackao nesto nakon instalacije lilo.conf fajl?

Ako pretpostavimo da ti se Windows nalazi na sda1 prepravi ovo:

Quote:

other = /dev/sda
  label = Windows
  table = /dev/sda1

u ovo:

Quote:

other = /dev/sda1
  label = Windows
  table = /dev/sda

a mozes probas i da izbacis table = /dev/sda

Ne znam koliko si u ovim vodama, cisto napomena, kad promenis tekstualni fajl /etc/lilo.conf izvrsi komadnu
# lilo

Ako ne prodje ni jedno, kao sto rece ak-87, cekamo da bacis listing:
#fdisk -l

__________________

All we have to decide is what to do with the time that is given to us. J.R.R. Tolkien

Kix
Slika korisnika Kix
Offline
User
Član od: 29/05/2006

Nakon instalacije nista nisam cackao to je sto je  Laughing out loud

#fdisk -l

Disk /dev/hda: 41.1 GB, 41110142976 bytes
255 heads, 63 sectors/track, 4998 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xabade207

  Device Boot      Start        End      Blocks  Id  System
/dev/hda1              1        2550    20482843+  83  Linux
/dev/hda2            2551        4935    19157512+  83  Linux
/dev/hda3            4936        4998      506047+  82  Linux swap

Disk /dev/sda: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x26ce077f

  Device Boot      Start        End      Blocks  Id  System
/dev/sda1  *          1        5100    40965718+  7  HPFS/NTFS
/dev/sda2            5101      38913  271602922+  f  W95 Ext'd (LBA)
/dev/sda5            5101      20399  122889186    7  HPFS/NTFS
/dev/sda6          20400      35698  122889186    7  HPFS/NTFS
/dev/sda7          35699      38913    25824456    7  HPFS/NT

@Spooky13
Prepravio neradi, kad sam ponovo pokrenuo #lilo prijavio mi je da je particija uspesno dodata

Warning: LBA32 addressing assumed
Added Windows *
Added Linux
One warning was issued

Koliko vidim sve se vrti oko LBA32

@ak-87

Jeste tako je bilo svih ovih godina bez problema sve do sad.

Spooky13
Slika korisnika Spooky13
Offline
User
Član od: 29/05/2006

Hmm.. jesam jos bunovan al mi nista nije jasno.. :/ Nema veze sto imas to upozorenje, samo dodas lba32 i upozorenje nestaje al butovanje treba da radi (bez/sa tim upozorenjem)..

1. U BIOS-u koji ti je hard stavljen da se prvi butuje (hda il sda)?
2. Dok si u Linuxu jel mozes montiras Windows particiju i da li je vidis?
# mount -t ntfs /dev/sda1 /mnt
# ls -la /mnt
3. Pre instalacije Slackware-a da nisi zonglirao sa vise istovremenih Windows instalacija, pa nekako sda1 mrtva/ostecena a taj Windows koji si koristio na nekoj drugoj particiji (npr. sda5)? Jesi 100% stiguran da ti se Windows koji radi nalazi na sda1?

Generalno ovaj lilo.conf treba da radi u tvom slucaju:

Quote:

append=" vt.default_utf8=0"
boot = /dev/hda
bitmap = /boot/slack.bmp
bmp-colors = 255,0,255,0,255,0
bmp-table = 60,6,1,16
bmp-timer = 65,27,0,255
lba32
prompt
timeout = 1200
vga = 773
default=Windows
compact

other = /dev/sda1
 label = Windows
 table = /dev/sda

image = /boot/vmlinuz
 root = /dev/hda1
 label = Linux
 read-only

4. Kada resujes komp, izaberes Windows sta se tacno desava, sta prijavi?

5. Edit: daj mi i listing:
# cat /etc/fstab

__________________

All we have to decide is what to do with the time that is given to us. J.R.R. Tolkien