[rešeno] SmartLink modem, Laptop problemi

36 odgovora [Poslednji unos]
dokman
Slika korisnika dokman
Offline
User
Član od: 31/05/2007

Upisao sam i jedno i drugo, opet isto.

Citao sam malo pazljivije tvoj prethodni post, da u boot.txt ima resenje za cudnu stvar koja se desava kod mene, u dmesg sam nasao
slamr: module license 'Smart Link Ltd.' taints kernel.
slamr: SmartLink AMRMO modem.
slamr: probe 8086:24c6 ICH4 card...
slamr 0000:00:1f.6: PCI INT B -> Link[LNKB] -> GSI 5 (level, low) -> IRQ 5
slamr 0000:00:1f.6: setting latency timer to 64
slamr: mc97 codec is SIL22
slamr: slamr0 is ICH4 card.
probao sam naci neko objasnjenje na netu za to, ali nisam uspeo, jos pise da se moze u bootloader u kernel liniju dodati
pci=routeirq
ili
pollirq
ali opet bez uspeha, izgleda da se zbog necega u toku boot-a desava
WvModem<*1>: Cannot get information for serial port
kad udarim
wvdialconf

Ne da mi se pa to ti je!

dokman
Slika korisnika dokman
Offline
User
Član od: 31/05/2007

Dede, Jovire reci mi "step by step" kako si osposobio svoj modem, PLEASE! Popizdi vise!

Probao sam onaj SLMODEMD.gcc4.1 i 4.2, u oba mi na
make
izbacuje
make: *** No targets specified and no makefile found.  Stop.

kao ne postoji "make" file, a u README pise da se on po potrebi menja ako nije dobro upisana putanja do kernela!

Nemam ideje!

Unapred hvala!

jovir
Slika korisnika jovir
Offline
User
Član od: 29/05/2006

Prvo budi siguran koju verziju gcc imaš, pa prema tome koristi SLMODEMD.gcc4.1 za gcc4.1 ili SLMODEMD.gcc4 za gcc4.2.
Ovo su kompajlirani drajveri, ne treba komanda make, već samo kao root pokreni skriptu setup...

dokman
Slika korisnika dokman
Offline
User
Član od: 31/05/2007

Uradio sam taj 4.2, posto je kod mene gcc4.2.4, zavrsi on to, ja pokusam da konfigurisem wvdial kad ono
wvdialconf /etc/wvdial.conf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: S0  S1  S2  S3

Sorry, no modem was detected!  Is it in use by another program?
Did you configure it properly with setserial?

Please read the FAQ at <a href="http://open.nit.ca/wiki/?WvDial" title="http://open.nit.ca/wiki/?WvDial">http://open.nit.ca/wiki/?WvDial</a>

If you still have problems, send mail to <wvdial-list@lists.nit.ca>.

nema mi nigde modema, sakrio se.

zato ti kazem da mi napises korak po korak, zamolio bi i cime se konektujes, koja je komanda za uspostavljanje veze itd.

ovo je iz
lspci
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 03)
tako vidi modem, jel isto i kod tebe?

jovir
Slika korisnika jovir
Offline
User
Član od: 29/05/2006

Prvo instaliraš slmodemd modul pomoću komande ./setup.
Pokreneš modem pomoću komande:
slmodemd --alsa -c SLOVENIA hw:0,6
Ovde može da bude modifukacija, odradi scanmodem, pročitaj "Readme"...
Zatim pokrećeš wvdial ili sl. za konektovanje, ne isključujući konzolu sa prethodnom komandom.
Kod mene je bio još jedan međukorak, instalirao sam Conexant HSF drajvere za modem koji su "oslobodili" ALSA zvuk na HDA modemu, i onda je sve proradilo...
Pozdrav!

dokman
Slika korisnika dokman
Offline
User
Član od: 31/05/2007

Hvala, nadam se da cu uraditi nesto.