opensuse11.4 staticka ip u LAN-u i problem pppoe konekcije

6 odgovora [Poslednji unos]
pasuljj
Slika korisnika pasuljj
Offline
User
Član od: 26/05/2011

pozdrav
instalirao sam opensuse 11.4 pre par dana i imam problem da idem na internet preko pppoe konekcije na mikrotik preko LAN-a
instalirao sam smpppd i qinternet sa 11.3 DVD-a jer ih nema na 11.4(ovo sam procitao na nekom forumu)
mogu da pingujem po ip adresi bilo sta, po imenu nesto moze a nesto nemoze,
mozilla otvara googla ako joj ukucam ip adresu ali ne i ako ukucam www.google.com

za pocetak ovo, a ako treba jos neki info kazite
hvala unapred

linux-0h5y:/home/vladimir # ifconfig
dsl0 Link encap:Point-to-Point Protocol
inet addr:10.11.108.90 P-t-P:10.10.108.12 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1000 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:64 (64.0 b) TX bytes:54 (54.0 b)

eth0 Link encap:Ethernet HWaddr 40:61:86:4E:90:51
inet addr:192.168.24.68 Bcast:192.168.24.255 Mask:255.255.255.0
inet6 addr: fe80::4261:86ff:fe4e:9051/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:33532 errors:0 dropped:10766 overruns:0 frame:0
TX packets:929 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4879727 (4.6 Mb) TX bytes:98365 (96.0 Kb)
Interrupt:41 Base address:0xc000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:139 errors:0 dropped:0 overruns:0 frame:0
TX packets:139 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:11567 (11.2 Kb) TX bytes:11567 (11.2 Kb)

linux-0h5y:/home/vladimir # ping google.com
PING google.com (209.85.149.103) 56(84) bytes of data.
64 bytes from ber01s02-in-f103.1e100.net (209.85.149.103): icmp_seq=1 ttl=53 time=39.8 ms
64 bytes from ber01s02-in-f103.1e100.net (209.85.149.103): icmp_seq=2 ttl=53 time=42.3 ms
64 bytes from ber01s02-in-f103.1e100.net (209.85.149.103): icmp_seq=3 ttl=53 time=41.8 ms
^C
--- google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2002ms
rtt min/avg/max/mdev = 39.859/41.364/42.396/1.088 ms
linux-0h5y:/home/vladimir # nslookup www.google.com
;; Got SERVFAIL reply from 192.168.24.250, trying next server
;; Got SERVFAIL reply from 10.10.108.12, trying next server
Server: 8.8.8.8
Address: 8.8.8.8#53

Non-authoritative answer:
www.google.com canonical name = www.l.google.com.
Name: www.l.google.com
Address: 209.85.149.99
Name: www.l.google.com
Address: 209.85.149.103
Name: www.l.google.com
Address: 209.85.149.147
Name: www.l.google.com
Address: 209.85.149.104
Name: www.l.google.com
Address: 209.85.149.105
Name: www.l.google.com
Address: 209.85.149.106

linux-0h5y:/home/vladimir # route -n
Kernel IP routing table
Destination _ Gateway _ Genmask _ Flags _Metric_ Ref _ Use_ Iface
10.10.108.12_0.0.0.0 _255.255.255.255_ UH _ 0 _ 0 _ 0 _dsl0
192.168.24.0_0.0.0.0 _255.255.255.0 _ U _ 0 _ 0 _ 0_ eth0
169.254.0.0_0.0.0.0 _255.255.0.0 _ U _ 0 _ 0 _ 0 _eth0
127.0.0.0 _0.0.0.0 _255.0.0.0 _ U _ 0 _ 0 _ 0 _lo
0.0.0.0 _0.0.0.0 _ 0.0.0.0 _ U _ 0 _ 0 _ 0 _dsl0

Zakačene slike: 
opensuse11.4 staticka ip u LAN-u i problem pppoe konekcije
Zakačene slike: 
opensuse11.4 staticka ip u LAN-u i problem pppoe konekcije
0
zokypoky
Slika korisnika zokypoky
Offline
User
Član od: 06/05/2009

Dovoljno je da iz YAST-a u softver sekciji otkucaš ime paketa i on će ga naći na Internetu u nekom od openSUSE-ovih repo-a, za 11.4. Nisi morao da se mučiš...

Za "dsl0" treba da imaš postavljen gejtvej i DNS server, kada se konektuješ. Na slici se to ne vidi...

Kako si povezan sa Internetom, jel preko mrežnog kabla na "eth0" sa ruterom?

bOSKE
Slika korisnika bOSKE
Offline
User
Član od: 30/04/2008

probaj da stavish ove dns servere
primary
8.8.8.8
i secondary
8.8.4.4

pasuljj
Slika korisnika pasuljj
Offline
User
Član od: 26/05/2011

ja sam nov u linuxu, procitao sam na nekom forumu da mi trebaju ta dva paketa
(smpppd i qinternet) e mislim da sam ih nasao ali prilimom instalacije jedan je trazio, nemogu tacno da se setim nesto kao atm-lib-???
i to nikako nisam uspeo da iskopam a na forumima sam procitao da je ovo problem kod 11.4 i da se preporucuje bas deinstalacija toga sto sam nasao za 11.4 i instalacija sa 11.3DVD, naravno ovo sam trazio sa windowsa jer je yast bez interneta bespomocan

da na mrezu sam zakacen preko eth0, mrezni kabl na switch i par switcheva dalje je mikrotik

malo cudno mi je forum zakacio slike, uglavnom kad se kilikne uvecaju se, evo ih sad malo preglednije

na prvoj se vidi da quinternet nije primio gateway tj stoji mu 0.0.0.0
na drugoj se vidi da sam dobio preko pppoe lokalnu adresu 10.11.108.90 (ova lokalna adresa bude postavljena za gateway kod windowsa),
remote adresu 10.10.108.12

takodje dobija i dva dns-a 10.10.108.12 i 8.8.8.8

evo kako to izgleda kod XP

i to je sad sve cudno za gateway mu stoji 0.0.0.0 ali oce da ode na internet sa ip adresom u browseru, moze da pinguje 8.8.8.8, pinguje i www.google.com ali ga u browseru otvara samo kad stavim 209.85.149.99

mikrotik deli local i remote adrese iz dve grupe adresa i tako da nije staticko

bOSKE
Slika korisnika bOSKE
Offline
User
Član od: 30/04/2008

10.10.108.12 taj dns si sam podesio ili ti je to od provajdera?

idi
sudo nano /etc/resolv.conf
i tu dodaj

nameserver 8.8.8.8
nameserver 8.8.4.4

ja inace koristim Arch. ja sam i u os-u i na ruteru stavio te dns servere..
ali mi je cudno shto ti pinguje www.google.com a na browseru nece da ti otvori.. :/ svejedno probaj ono :0
shto se tice gateway-a to nz dal treba da ti bude prema ruteru ili prema switchu,nisam toliko upucen u mrezhe..Smile

pasuljj
Slika korisnika pasuljj
Offline
User
Član od: 26/05/2011

mikrotik deli local i remote adrese iz dva spoola, tj iz dve grupe adresa,
dakel 10.10.108.12 dobijem od mikrotika, inace i 8.8.8.8 preko pppoe dobijem kao secondary DNS(to se vidi sa druge slike u mom prethodnom postu).
dobio sam dozvolu da se privremenio kacim na net koji nije u mom subnetu, ali je u fizickoj mrezi i kad stavim kao sto ti predlazes staticke gateway i DNS opensuse ide na net(obe adrese IP lokalne od tog rutera),
ali ovo je privremeno.
uglavnom sad mogu da probam i nesto preko yast update-a pa ako ineko ima ideju nek predlozi, btw to je comp na poslu tako da cu moci da probam tek u ponedeljak, do tada cekam vase ideje i predloge

za sada sumnjam na gateway, tj da se preko pppoe ne podesi pravino gateway ali nemam ideju kako to da namestim, mada sa druge strane samim tim sto kucanjem ip adrese u browser mogu da idem na net upucuje da je neki gateway prihvacen, to onda pokazuje da je problem mozda u DNS ali aj mogu da pingam google po imenu, i tu sad pocinjem da sumnjam da me mikrotik zeza jer je on i dns za lokal neznam zbunjen sam

mozda da mi neko kaze koje fajlove da obrisem i sta da deinstaliram i da postavim sve iz pocetka, sad imam i pristup netu(onaj privremeni) na tom compu pa mogu i preko yast-a da trazim sta treba

pff al sam se raskuco

pasuljj
Slika korisnika pasuljj
Offline
User
Član od: 26/05/2011

nece pa nece
a nemogu ni na google da nadjem odgovor
odustajem od 11.4
probacu sa 11.2 taj je valda dovoljno sazvakan i ima resenja za sve bug-ove