Instalacija nove verzija PHP-a

38 odgovora [Poslednji unos]
Barone
Slika korisnika Barone
Offline
User
Član od: 24/11/2006

Ubuntu 8.10.
Imam vec instaliran Lampp pod /opt/lampp.
I sada zelim noviju verziju php-a da instaliram.
U windowsu sam vec instalirao. Tamo mi wampp napravi 4 direktorijuma ( apache, php5, mysql i www)
I sve sto je pod php je u tom folderu php5. I za 30 sec dobijem novu verziju php-a bez muke i mozganja.
Kod Linuxa-se ne snalazim. PHP skripte imam svuda u vise foldera pod lampp ne na jednom mestu...
Sva upustva koja sam pogledao kazu da pod /usr/local/ instaliram i nadjem tamo mysql i php. Ali ja tu nemam nista od toga. Kod mene je lampp pod /opt sve instalirao.
Kako resiti problem? Afro

0
DrLove73
Slika korisnika DrLove73
Offline
User
Član od: 29/05/2006

Zavisi kako si instalirao sadasnji LAMP. Redovno preko Sinaptic-a (ili vec sta Ubuntu koristi) ili preko source-a (nije preporucljivo)?

Barone
Slika korisnika Barone
Offline
User
Član od: 24/11/2006

Skinuo source i :

sudo tar xvf xampp-linux-1.7.2.tar.gz -C/opt

Ovo je radjeno po upustvu, i uvek na ovaj nacin instaliram.

http://www.worldoweb.co.uk/2009/install-lampp-in-linux-mint ( ovo je jedan od sajtova koji objasnjava postupak )

DrLove73
Slika korisnika DrLove73
Offline
User
Član od: 29/05/2006

Onda valjda skines novu verziju XAMPP-a i sve Jovo nanovo.

Svaka Linux distribucija ima svoje Apache, PHP, MySQL itd pakete. Normalno je da se koriste ti paketi i da se updatuje preko repozitorijuma kada nova verzija za taj distro bude dostupna.

Izvini sto cu ovo reci, ali MOJE misljenje je da je taj nacin instalacije idiotski. Jeste da je lakse, ali ja takvo djubre na moj Linux racunar ne bih stavio, vec bi lepo sve odradio kroz distribuciju. Nikada ne znas sta su zabrljali, a drzati servise u /opt folderu? Ne hvala, nikada.

Evo Uputstava "po PS-u":
http://www.howtoforge.com/installing-apache2-with-php5-and-mysql-support...
http://www.howtoforge.com/perfect-server-ubuntu-8.10

Barone
Slika korisnika Barone
Offline
User
Član od: 24/11/2006

Ma ovo sa sa xampp ( http://www.apachefriends.org/en/xampp-linux.html#374 ) odatle je sve poteklo  ^-^
I do sada je uvek sljakalo bez problema, cak i za php framework i klase... dok nisam probao da poguram simfony , i napravilo brdo problema oko podesavanja servera i  modula. Tongue
Ma mrzelo me da instaliram novu verziju, mislio da moze nesto fast kao kod windowsa, ali izgleda da ne moze  Cool

zokypoky
Slika korisnika zokypoky
Offline
User
Član od: 06/05/2009

Ma može, i te kako !

Svaka distribucija, pa i Ubuntu, ima svoje repozitorijume. Ubuntu mislim da ima Apt. Pogledaj malo spisak repozitorijuma (kao kod M$ kad gledaš odakle će da skineš apdejt!) za Apt, pa dodaj u spisak eventualno one koji fale, a zatim samo pokreni apdejtovanje i to je to!

Po meni čak i lakše nego na Windows-u, jer se pri tome sve automatski ažurira, a sam proizvođeč distribucije se brine o međuzavisnostima, pa tako i prateći softveri i biblioteke bivaju ažurirani automatski. Na Windowsu je dosta toga statički linkovano, pa je često nemoguće ažurirati biblioteke na nivou OS-a (osim sistemskih). Tu naravno ima dosta redundancije, ali ko te pita za to, naizgled je kobajagi lakše.

Očekuješ da ti se tvoj Ubuntu ponaša kao Windows - POGREŠNO! Isto onako pogrešno ako bi očekivao obrnuto. Ako želiš da koristiš RENAULT 4 moraš prihvatiti da je menjač u vidu kišobrana i to je to, tako je i sa Linuxom.

DrLove73
Slika korisnika DrLove73
Offline
User
Član od: 29/05/2006

zokypoky wrote:

Ako želiš da koristiš RENAULT 4 moraš prihvatiti da je menjač u vidu kišobrana i to je to, tako je i sa Linuxom.

I moras da prihvatis da ako imas damu na suvozackom sedistu ne moras da preskaces normalan menjac  ;), a o obaranju prednjih sedista tako da postanu celina sa zadnjim sedistima (king size) da i ne govorimo hehehe  >:D  :angel:  :p
Potpis: prezadovoljni vozac Resho-a 4 vec 17 godina.

zokypoky
Slika korisnika zokypoky
Offline
User
Član od: 06/05/2009

Boga mi Ljubomire vidim da si ti svoj Resho 4 zloupotreljavao....
Ja sam ga vozio 12 godina i žao mi je kada sam ga prodao!

P.S. Nisam ga zloupotrebljavao!

dukenukem_4d
Slika korisnika dukenukem_4d
Offline
User
Član od: 02/07/2007

Lol Laughing out loud => ipak... 'stojadin' nema alternative... ^-^
Afro

__________________

ADSL 1024 Slackware Srbija?Psy linux> Notorrni_modem ali se teže instalira od oootranslit ња ња

Barone
Slika korisnika Barone
Offline
User
Član od: 24/11/2006

Evo sam resio tako sto sam skinuo najnoviju verziju xamppa.
Ali imam drugi problem.... Treba mi PDO .
Narocito pdo_mysql.so
Kada proverim preko konzole pise da je PDO...ok i PDO da je instaliran drajver za mysql.

Znaci vec imam instaliran lampp u /opt/lampp/.

Ali da bih radio u konzoli trebalo mi je i php naredba
tipa $php chack_configuration.php // recimo
Ja sam instalirao preko konzole....kada je zatrzio i javio gresku ( naravno ovo nije otislo pod /opt
Posto je pravio problem za pdo_mysql.so , preko synaptica sam instalirao i php5_mysql ... :laugh:
I sada mi izbacuje
Code:

PDO Connection Error: SQLSTATE[HY000] [2002] Can't con...erver through socket '/var/run/mysqld/mysqld.sock' (2)

Znaci nasao sam pdo_mysql.so u /usr/lib/php5/... a meni je ceo LAMP pod /opt/lampp
Kopirao sam tih par fajla sa *.so pod lampp u ekstenzije i dopisao redove u php.ini
, restartovao apache i dalje isti problem.

Znaci kako podesiti PDO drajver pod /opt/lampp ? Ovaj nacin mi vise odgovara, posto je sve na jednom mestu
Ili moram da instaliram sve preko synaprica a na ovo raspakivanje zaboravim ... Sta da radim  :'(

DrLove73
Slika korisnika DrLove73
Offline
User
Član od: 29/05/2006

Moj savet je da ides sa paketima uz distribuciju. Kad jednom namestis, automatski se updatuje. Di ces bolje.

Ako tako rade ogromne firme i 99,9999% pojedinaca...